← Archive

Resolving Snipe-IT Synology Folder Permissions

Archived post · originally published · may be out of date

Synology · #Snipe-IT #Synology


Article inspiration:

Intro

I had a bizarre issue recently with a brand new Synology that I was deploying Snipe-IT to, where during the pre-flight check I was greeted with the following error message:

I have deployed Snipe-IT to various Synology environments, specifically the superior linuxserver version, and this was the first time this issue came up. One solution was to deploy Snipe-IT with a Docker volume but my preference with containers on a Synology is to use bind mounts instead (as I find it easier to backup the files with this method). I have noticed in the past that Synology devices handle container folder permissions differently compared to if you were running Docker natively on a Linux server. Clearly this error message was caused by a folder permissions issue but I was uncertain how to actually fix the problem:

Snipe-IT-01

Solution

After contacting Marius Hosting for a hand, he showed me that the solution is straightforward:

  1. Select the folder that will contain your future Snipe-IT deployment and open the File Station properties menu Snipe-IT-03
  2. What we are going to do is make the permissions for this folder explicit so we will then select Make inherited permissions explicit Snipe-IT-04
  3. Next we will select Apply to this folder, sub-folders and files Snipe-IT-05
  4. Finally, we will grant the Everyone group write permissions to this folder and then apply these new permissions Snipe-IT-06
    Once completed, when you go to the Snipe-IT pre-flight page, everything should be green:
Snipe-IT-02